× Появилась потребность в данном разделе. Каждый может поделиться своим программным продуктом или рассказать о чужом.

Сборник программ автоматической установки и настройки для работы с ГИС-ами

21 янв 2020 03:57 - 12 авг 2021 05:33 #14934 от shaburoff
Предлагаю вам протестировать комплект программ автоматической установки и настройки для работы с ГИС-ми, на основе MInstAll – мастера установки приложений. Процесс установки и настройки программ и компонентов происходит в автоматическом режиме после выбора необходимого софта.

Мной протестирована установка всех возможных программ в зависимости от версии ОС и её разрядности на Windows 7x86/7x64/10x64(1909)/10x86(2004) с отключенным контролем учётных записей (UAC). Частично проверена работоспособность СУФД/ЕИС по 44-ФЗ раздел 3 порядка 27н/Электронный бюджет ФК и МинФина.

Всё ПО, представленное в комплекте без лицензионных ключей!

Системные требования – Windows 7/8/10 как x86, так и x64

Состав сборника от 12.08.2021: [ Нажмите, чтобы развернуть ]


Изменения: [ Нажмите, чтобы развернуть ]


Скриншоты [ Нажмите, чтобы развернуть ]


ВНИМАНИЕ: Для установки Jinn-клиента и eXtended Container желательно ввести лицензионные ключи до их установки, т.к. в дальнейшем ввести ключи будет проблематично. Для того чтоб ввести ключи необходимо отредактировать в мастере установки “Ключи запуска”. Как это сделать, наглядно показано на скриншотах ниже:

Скриншоты [ Нажмите, чтобы развернуть ]


Примечание: [ Нажмите, чтобы развернуть ]


Надеюсь получить от вас конструктивную критику и предложений по улучшения этого сборника программ, а так же о наличии ошибок:).

СКАЧАТЬ:


Часть сообщения скрыта для гостей. Пожалуйста, авторизуйтесь или зарегистрируйтесь, чтобы увидеть его.
Вложения:
Спасибо сказали: sedkazna, sam28daphne, RecobaFED, andreyfoxter, dimas36, Старый, Van, Remand, redredred, vovan260274, sergey77726

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

21 янв 2020 04:58 #14936 от ful
С ключами замороченно получилось. Думаю было бы понятнее, если после выбора необходимых программ выходило окошко типа "Для постоянной работы выбранных вами программ необходимо ввести лицензионные ключи" и окошко, где указаны программы, а рядом поле для ввода лицензии. Ну и снизу кнопка, продолжить установку без ввода лицензионных ключей и далее) Ну и конечно для обычного пользователя сделал бы окошко типа Расширенная установка и типовая установка и для типовой - "В каких ГИСах необходимо работать" и на основании выбора, автоматически ставить необходимое ПО.
Спасибо сказали: shaburoff, Старый

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

21 янв 2020 13:06 #14953 от shaburoff
Да с лиц.ключами не очень удобно. Добавил обновление от 21.01.2020 изменил запуск установки Jinn-Client через bat-файл (Спасибо FarWinter, подглядел у него тут ). Теперь при запуске установки Jinn происходит запрос на ввод лицензионного ключа. По мне установка так получается менее автоматизирована.
По eXtended Container как я понял один лиц.ключ на всех, т.е. его нужно ввести один раз и забыть или скачать обновление из шапки.
Спасибо сказали: Remand

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

19 фев 2020 01:16 #15326 от Remand
очень удобный софт спасибо! помог быстро настроить рабочее место!! спасибо!!!

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

21 фев 2020 23:55 #15397 от SibUrsus
Очень нужный и полезный проект!
Если можно, пара вопросов и хотелок:
1. Драйверы Рутокен. На оф сайте лежат 4.8.1.0 от 04.12.2019 а у вас 2.89.00.0491. Что это?
2. В браузеры, если можно, добавьте Спутник с поддержкой отечественной криптографии. Хромиум ГОСТ, ну такое, по крайней мере пока они с Доктором Вебом не помирятся.
3. В удаленный доступ, кмк, сейчас более актуален AnyDesk.
4. Посмотрите внимательно на работу help.kontur.ru, возможно у них подсмотрите что-то полезное, юзаем активнейше, удобная штука.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

25 фев 2020 06:16 - 25 фев 2020 06:21 #15401 от ranger
вновь и вновь древняя ява - решето
что ж народ заклинило то на ней...

ладно еще 8 версия куда ни шло (хотя уже принято использовать AdoptOpenJDK)

поясните для чего вы пихаете яву? для каких целей?
если это софт для операторов ФК - оделите от софта для простых смертных, не надо их мешать, пожалуйста (сделайте два инсталлятора)
для простых людей ява НАФИК не нужна ни в одной из ГИС


P.S. в свете того, что ЭБ сейчас работает без TLS и говнософта от КБ (вход по https), половину можно выпилить

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

25 фев 2020 06:24 - 25 фев 2020 06:32 #15403 от Alex_04

ranger пишет: для простых людей ява НАФИК не нужна ни в одном из ГИС

Для непростых пользователей СУФД это древнее поделие всё-ещё нужно (вроде как). Не для подписания -- для отработки прочих операций с документами, хотя могу и ошибаться.

ладно еще 8 версия куда ни шло

С этим можно согласиться -- и на 8.х в СУФД работает норм при должных настройках явы.

в свете того, что ЭБ сейчас работает без TLS и говнософта от КБ (вход по https), половину можно выпилить

В этом есть резон, НО если быть уверенным на все 100%, что после каких-нить очередных обнов за...мечательного ПО ЭБ не выснится (вдруг), что всё в ЭБ будет корректно работать только по http...
Поэтому, имхо: с ЭБ лучше перебдеть, чем недобдеть.


Бесконечно можно смотреть на 3 вещи: огонь, воду и ... открытие сайта "веселые картинки" ГМУ (опыт IT-шника)

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

25 фев 2020 13:02 #15416 от SibUrsus

поясните для чего вы пихаете яву? для каких целей?

Ви только не обижайтесь, я вам адын умный вэщь скажу (с)

В РФ, а в Сибири и более восточных регионах в частности, есть очень-очень много МФЦ, которым "повезло" работать с АИС МФЦ от конторы AT Consulting Vostok. И мы, как гвоздями приколочены к их Smart Agent-у. А это java. И это много-много рабочих мест, которые работают с многими ГИС.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

26 фев 2020 06:36 - 26 фев 2020 06:43 #15431 от ranger

SibUrsus пишет: В РФ, а в Сибири и более восточных регионах в частности, есть очень-очень много МФЦ, которым "повезло" работать с АИС МФЦ от конторы AT Consulting Vostok. И мы, как гвоздями приколочены к их Smart Agent-у. А это java. И это много-много рабочих мест, которые работают с многими ГИС.

Так я и говорю - вы как-то отделите одно от другого, а то начнут всё в подряд ставить.

Кстати, лиса старая, используйте сборку ESR (вроде 52 крайняя, которая с плагинами нормально работает - с той же явой).

Alex_04 пишет: Для непростых пользователей СУФД это древнее поделие всё-ещё нужно (вроде как). Не для подписания -- для отработки прочих операций с документами, хотя могу и ошибаться.

Не нужно. Если не использовать расширенный импорт файлов (что очень редкое явление). И опять же 8 версия отлично работает. Но 6 и 7 - это решето.

В этом есть резон, НО если быть уверенным на все 100%, что после каких-нить очередных обнов за...мечательного ПО ЭБ не выснится (вдруг), что всё в ЭБ будет корректно работать только по http...
Поэтому, имхо: с ЭБ лучше перебдеть, чем недобдеть.

Согласен. Но держать в качестве дистрибутивов и при необходимости быстро установить.
Плюс еще есть ЕТД (тоже не 100% гарантия работы, но один из вариантов).

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

26 фев 2020 14:15 - 26 фев 2020 14:17 #15450 от Alex_04

ranger пишет:

Alex_04 пишет: Для непростых пользователей СУФД это древнее поделие [ java ] всё-ещё нужно (вроде как).

Не нужно. Если не использовать расширенный импорт файлов (что очень редкое явление).

Спасибо за это уточнение -- полезное знание. :)


Бесконечно можно смотреть на 3 вещи: огонь, воду и ... открытие сайта "веселые картинки" ГМУ (опыт IT-шника)

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

27 фев 2020 06:09 #15456 от SibUrsus

Так я и говорю - вы как-то отделите одно от другого, а то начнут всё в подряд ставить.


Уж очень вы суровы и строги к нам, бедолагам. Эту сборку все таки будут ставить хоть хроменькие, кривенькие, но все таки ойтишники, они уж как-нибудь разберутся, какие флажки ставить а какие нет :)

Кстати о ламерах. Можно ли сделать такой батник или я не знаю, чтоб сразу открывал Блокнот от админа и вносил правки в файл hosts? DrWeb возражать не будет.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

27 фев 2020 06:29 - 28 фев 2020 06:51 #15457 от Alex67

SibUrsus пишет: Можно ли сделать такой батник или я не знаю, чтоб сразу открывал Блокнот от админа и вносил правки в файл hosts? DrWeb возражать не будет.

Ну, как то так (допишется в конец файла):
(закорючки это слово Все сохранённое в ansi а не в dos кодировке.
Так надо для русской винды.
@echo off
if exist %systemroot%\SysWOW64 (
set hosts=%systemroot%\SysWOW64\drivers\etc\hosts
) else (
set hosts=%systemroot%\System32\drivers\etc\hosts
)
cacls %hosts% /E /G All:F
cacls %hosts% /E /G ‚бҐ:F
attrib -s -r -h %hosts%
(echo.
echo # SUFD PORTAL
echo 10.66.200.66 s6400w03.ufk64.roskazna.local
echo 10.66.200.66 sufd.s6400w03.ufk64.roskazna.local
echo # END SUFD PORTAL
)>>%hosts%
cacls %hosts% /E /R All
cacls %hosts% /E /R ‚бҐ
ipconfig /flushdns

Р.S. Просили пример батника пишущего в хостс.
Просьба не устраивать "суфдхостосрач" :)


"Кто людям помогает - лишь тратит время зря. Хорошими делами прославиться нельзя" (с) Шапокляк

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

05 март 2020 09:35 - 05 март 2020 09:36 #15537 от shaburoff

SibUrsus пишет: Очень нужный и полезный проект!
Если можно, пара вопросов и хотелок:
1. Драйверы Рутокен. На оф сайте лежат 4.8.1.0 от 04.12.2019 а у вас 2.89.00.0491. Что это?
2. В браузеры, если можно, добавьте Спутник с поддержкой отечественной криптографии. Хромиум ГОСТ, ну такое, по крайней мере пока они с Доктором Вебом не помирятся.
3. В удаленный доступ, кмк, сейчас более актуален AnyDesk.
4. Посмотрите внимательно на работу help.kontur.ru, возможно у них подсмотрите что-то полезное, юзаем активнейше, удобная штука.

1. Драйвера Рутокен и Етокен и взял из дистрибутива Jinn-Client 1.0.3050 распространяемого ФК, в следующей сборке обновлю.
2. Есть запрос на браузер Спутник, то могу добавить.
3. Да в удаленный доступ добавлю AnyDesk, т.к. TeamViewer уже бесить начинает при наличии лицензии я не могу пользоваться.
4. Согласен, сам не раз пользовался.

ranger пишет: вновь и вновь древняя ява - решето
что ж народ заклинило то на ней...

P.S. в свете того, что ЭБ сейчас работает без TLS и говнософта от КБ (вход по https), половину можно выпилить

А я не заставляю ставить Java, каждый решает сам ставить или нет. Знаю, что в СУФД давно уже без ней можно обойтись. Было раньше нужна для какого-то компонента ЭБ, сейчас не знаю нужна ли Java для ЭБ?
В следующей сборке выпилю Java или оставлю только 8 версию. Хотя вам ни кто не мешает убрать любые не нравящиеся компоненты из сборника.
Вот насчет ЭБ через https (без использования tls и jinn)ранее что-то не работало там, сейчас не знаю, надо будет проверить.

ranger пишет: Кстати, лиса старая, используйте сборку ESR (вроде 52 крайняя, которая с плагинами нормально работает - с той же явой).

Изначально в сборник добавил Firefox именно 52 esr версию, но почему то она с плагинами не заработала.
Спасибо за конструктивную критику и предложения.
И жду еще предложений по улучшению сборника, для этого он в открытый доступ и выложен.
Сертификаты ФЗС и новый УЦ ФК добавить нужно.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

05 март 2020 11:50 - 05 март 2020 13:34 #15538 от Alex_04

shaburoff пишет: Знаю, что в СУФД давно уже без ней можно обойтись. Было раньше нужна для какого-то компонента ЭБ, сейчас не знаю нужна ли Java для ЭБ?

Судя по сообщениям форумчан -- и в ЭБ не нужна Java (про СУФД всё же есть сомнения, лично мои).

Вот насчет ЭБ через https (без использования tls и jinn)ранее что-то не работало там, сейчас не знаю, надо будет проверить.

Тоже здесь писали -- починили в ЭБ работу при входе по https (была проблема с доступностью формуляров и при работе с некоторыми документами). Сам проверял только вход и просмотр доков в формулярах -- да вроде всё нормально.

shaburoff пишет:

ranger пишет: Кстати, лиса старая, используйте сборку ESR (вроде 52 крайняя, которая с плагинами нормально работает - с той же явой).

Изначально в сборник добавил Firefox именно 52 esr версию, но почему то она с плагинами не заработала.

Воткни 45.9.0esr -- должна норм со всеми плагинами работать (после неё ESR только 52, в промежутке других не было).


Бесконечно можно смотреть на 3 вещи: огонь, воду и ... открытие сайта "веселые картинки" ГМУ (опыт IT-шника)
Спасибо сказали: shaburoff

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

06 март 2020 05:46 - 06 март 2020 05:47 #15539 от Alexer81

Alex_04 пишет: Тоже здесь писали -- починили в ЭБ работу при входе по https (была проблема с доступностью формуляров и при работе с некоторыми документами). Сам проверял только вход и просмотр доков в формулярах -- да вроде всё нормально.

Вход и просмотр работал, но у клиентов не грузились вложения(не знаю что точно, кажется ФО сообщали). Так что пришлось им всё таки работать через Континент ТЛС.
Сами в отделе попробовали работать, оказалось невозможно. Мало того что тормозит, ещё кнопок то там то сям нет, не одно и тоже оказалось. Больше не пробовали.
Так что надо проверять.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.