× Функционирование и эксплуатация Государственной интегрированной информационной системы управления общественными финансами "Электронный бюджет" (ГИИС ЭБ).

Jinn-client

07 нояб 2018 04:21 - 07 нояб 2018 04:28 #9235 от Gvinpin

AlexMMM пишет: У нас на согласовании заявок все работает нормально, а все проблемы при утверждении. Вчера не проверяли, пока не на чем. Поэтому и решил сперва, что дело в конкретном рабочем месте. Имхо, там от всяких включений отключений плагинов ничего не изменится, объект с типом конкретного плагина инициализируется совершенно однозначно, а не так "эй кто тут из плагинов отвечает за ЭП?". Думаю что по ошибке вызывается крипто-про браузер плагин. Код попутали с другой подсистемой. А для IE обычно всегда отвечает отдельная ветка кода. Поэтому и работает. Вот как-то так.

Может "вызываться" КриптоПро плагин (если не выключен), может Java. Имхо, это не специально, а уже по причине того, что "не вызвался" Jinn.

Нас невозможно сбить c пути — нам все равно куда идти ©

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

07 нояб 2018 09:19 - 07 нояб 2018 09:22 #9237 от Gvinpin

Wmffre пишет: Дистрибутив JinnSignExtensionSetup.msi версии 1.1.0.5 официально пока не достать. В дистрибутиве ПАК Jinn-Client 1.0.3050.0 в папке prerequisites есть JinnSignExtensionSetup.msi версии 1.1.0.4, но с этой версией расширение для firefox работать не будет.

Ссылка на инструкцию , полученную из группы скайпа, внутри которой вложены необходимые файлы.

ПРИМЕЧАНИЕ: В Google Chrome разных версий подпись настроить все равно не получилось. В Internet Explorer 11 подпись работает даже без установки JinnSignExtensionSetup.msi. В Mozilla Firefox 55.0, настроенном по указанной инструкции, всё работает.

Еще раз спасибо, сегодня все получилось на рабочем компьютере - после того, как старая версия Firefox была удалена через Revo Uninstaller. Видимо, вчера удаление cookie и кэш не помогло.
Сначала были полностью удалены браузер и Jinn-Client, затем все установлено с нуля по инструкции, только браузер не последней версии, а 55 (в инструкции - на ниже 55, но рекомендуется последнюю). Версия Jinn-Client - 1.0.3050.

Нас невозможно сбить c пути — нам все равно куда идти ©

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

07 нояб 2018 10:18 #9239 от AlexMMM
Gvinpin

А версией Jinn-Client 1.0.3050 не поделитесь?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

07 нояб 2018 11:42 #9240 от Gvinpin

AlexMMM пишет: Gvinpin

А версией Jinn-Client 1.0.3050 не поделитесь?

Да, только попозже )

Нас невозможно сбить c пути — нам все равно куда идти ©

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

07 нояб 2018 15:18 - 07 нояб 2018 16:42 #9241 от Gvinpin

Нас невозможно сбить c пути — нам все равно куда идти ©
Спасибо сказали: SanTa27

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

07 нояб 2018 15:33 #9242 от AlexMMM
Gvinpin
Недостаточно прав для просмотра этого файла

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

07 нояб 2018 16:43 #9243 от Gvinpin

AlexMMM пишет: Gvinpin
Недостаточно прав для просмотра этого файла

А сейчас?

Нас невозможно сбить c пути — нам все равно куда идти ©
Спасибо сказали: AlexMMM

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

07 нояб 2018 17:55 - 07 нояб 2018 17:56 #9244 от Blaze
В сводном реестре делаем заявки в Pale Moon на изменение инфы по учреждениям. Подписываем без проблем =)

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

08 нояб 2018 05:42 - 08 нояб 2018 14:56 #9245 от Alex67

Blaze пишет: В сводном реестре делаем заявки в Pale Moon на изменение инфы по учреждениям. Подписываем без проблем =)

Социальная реклама:
ЭЛЕКТРОННЫЙ БЮДЖЕТ: НАЙДИ СВОЙ БРАУЗЕР!
Криптопрофокс 45.1.2

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

08 нояб 2018 12:18 #9246 от AlexMMM
Gvinpin

Еще раз спасибо, все получилось. Firrefox портабельный использовал 62 версии. Да, тоже удалять пришлось предыдущий, благо с портабельной версией не нужно заморачиваться никакими унинсталерами.
Единственно радость омрачают кракозябры в маленьком окошке где пин-код запрашивается при подписании. У вас также?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

08 нояб 2018 15:56 #9247 от Gvinpin

Gvinpin пишет:

Alex67 пишет: На всякий случай, вдруг поможет: Кубический плагин надо так же "передёрнуть" как я выше описывал т.е. в "по запросу"

По-моему, он вообще не нужен... На одной машине был удален, чтобы скачать актуальную версию. Все подписалось без него...

Точнее, он нужен только для КУБа.

Нас невозможно сбить c пути — нам все равно куда идти ©

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

15 нояб 2018 09:35 #9277 от MotoArhangel

Gvinpin пишет:

Gvinpin пишет:

Alex67 пишет: На всякий случай, вдруг поможет: Кубический плагин надо так же "передёрнуть" как я выше описывал т.е. в "по запросу"

По-моему, он вообще не нужен... На одной машине был удален, чтобы скачать актуальную версию. Все подписалось без него...

Точнее, он нужен только для КУБа.

Да и для куба не обязателен наверное. И без него все нормально работает.


Не волнуйтесь, если что-то не работает. Если бы всё работало, Вас бы уволили. =)

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

15 нояб 2018 10:36 #9278 от Gvinpin

MotoArhangel пишет:

Gvinpin пишет:

Gvinpin пишет:

Alex67 пишет: На всякий случай, вдруг поможет: Кубический плагин надо так же "передёрнуть" как я выше описывал т.е. в "по запросу"

По-моему, он вообще не нужен... На одной машине был удален, чтобы скачать актуальную версию. Все подписалось без него...

Точнее, он нужен только для КУБа.

Да и для куба не обязателен наверное. И без него все нормально работает.

Нормально работает - это заявки и без подписания сохраняются и выполняются (ДА) или подписываются без плагина (НЕТ)?

Нас невозможно сбить c пути — нам все равно куда идти ©

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

15 нояб 2018 13:09 #9282 от Alex_04

MotoArhangel пишет:

Gvinpin пишет:

Gvinpin пишет:

Alex67 пишет: На всякий случай, вдруг поможет: Кубический плагин надо так же "передёрнуть" как я выше описывал т.е. в "по запросу"

По-моему, он вообще не нужен... На одной машине был удален, чтобы скачать актуальную версию. Все подписалось без него...

Точнее, он нужен только для КУБа.

Да и для куба не обязателен наверное. И без него все нормально работает.

А ведь действительно: для чего нужен куб-плагин? При входе в сам "КУБ" задействуется сначала TLS-клиент, затем выбор ЭП идет через Jinn, если не ошибаюсь. Заявки в "КУБ" подисываются тоже через джин-плагин - его окно явно на этом этапе видно. Ну и при кем тогда куб-плагин?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

15 нояб 2018 14:19 - 15 нояб 2018 22:31 #9283 от Gvinpin

Alex_04 пишет: А ведь действительно: для чего нужен куб-плагин? При входе в сам "КУБ" задействуется сначала TLS-клиент, затем выбор ЭП идет через Jinn, если не ошибаюсь. Заявки в "КУБ" подисываются тоже через джин-плагин - его окно явно на этом этапе видно. Ну и при кем тогда куб-плагин?

А раньше был при кем?
Если Firefox не поддерживает плагины (ну или cube-плагин не установлен), то возникает предупреждение: "Подпись заявки невозможна. Не найден модуль формирования электронной подписи" + предложение, от которого невозможно отказаться ссылка для скачивания. Иначе заявка сохраняется без подписи регистратора, а потом благополучно выполняется.
(Из-за этого не получилось работать в КУБ на Firefox 55 версии).

Нас невозможно сбить c пути — нам все равно куда идти ©

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.